November 2007

Quick Correct: A Method to Automatically Evaluate Student Work in MS Excel Spreadsheets

Laura R. Wetzel
Eckerd College, wetzellr@eckerd.edu

Peter J. Whicker
Eckerd College, whickepj@eckerd.edu

Follow this and additional works at: http://epublications.bond.edu.au/ejsie

This work is licensed under a Creative Commons Attribution-Noncommercial-No Derivative Works 4.0 License.

Recommended Citation
Available at: http://epublications.bond.edu.au/ejsie/vol2/iss3/1
Quick Correct: A Method to Automatically Evaluate Student Work in MS Excel Spreadsheets

Abstract
The quick correct method allows instructors to easily assess Excel spreadsheet assignments and notifies students immediately if their answers are acceptable. The instructor creates a spreadsheet template for students to complete. To evaluate student answers within the template, the instructor places logic functions (e.g., IF, AND, OR) into a column adjacent to student responses. These “quick correct” formulae are then password protected and hidden from view. If a student enters an incorrect answer while completing the spreadsheet template, the logic function returns an appropriate warning that encourages corrections.

Keywords
spreadsheets, Excel, grading, logic functions

Distribution License
This work is licensed under a Creative Commons Attribution-Noncommercial-No Derivative Works 4.0 License.

This in the classroom article is available in Spreadsheets in Education (eJSiE): http://epublications.bond.edu.au/ejsie/vol2/iss3/1
Quick Correct: A Method to Automatically Evaluate Student Work in MS Excel Spreadsheets

Laura Reiser Wetzel  
Department of Marine Science  
Eckerd College  
Saint Petersburg, FL  
wetzellr@eckerd.edu

Peter J. Whicker  
Department of Marine Science  
Eckerd College  
Saint Petersburg, FL  
whickepj@eckerd.edu

Abstract

The quick correct method allows instructors to easily assess Excel spreadsheet assignments and notifies students immediately if their answers are acceptable. The instructor creates a spreadsheet template for students to complete. To evaluate student answers within the template, the instructor places logic functions (e.g., IF, AND, OR) into a column adjacent to student responses. These “quick correct” formulae are then password protected and hidden from view. If a student enters an incorrect answer while completing the spreadsheet template, the logic function returns an appropriate warning that encourages corrections.

Keywords: spreadsheets, Excel, grading, logic functions.

1. Introduction

One of the most onerous tasks in teaching is correcting student papers. By using logic functions and password protections within MS Excel, instructors can create spreadsheet templates that automatically evaluate students’ work. This also allows instructors to change spreadsheets slightly from student to student and automatically create an answer key.

2. Quickly Correcting Spreadsheets

The basic idea is to automatically check for the correct value when students input a formula. In this way, students will know immediately if the work is correct or the instructor may hide this information and display it later to correct student work with greater ease.

© 2007 Spreadsheets in Education, Bond University. All rights reserved.  
2.1. Creating a Template

For any assignment, an instructor creates an Excel template that is electronically distributed to students. The minimum information in the template is a column specified for student answers and a corresponding column containing logic functions that automatically assess the student answers. In the example in Fig. 1, students are provided with numbers in the yellow cells (left), are asked to fill in the appropriate formulae in the orange cells (center), and are provided with “quick correct” information in the green cells (right).

![Figure 1: Assignment template as seen by a student (top) and as created by an instructor (bottom). The earthquake magnitude scale is logarithmic, so each step in magnitude (MW) represents a ten-fold increase in seismogram amplitude.](image)

In this case the quick correct formula consists of the IF function with the correct formula, a “correct” answer message, and a “change” answer message, respectively. The logic functions AND, OR, TRUE and FALSE may also be used in Excel. The logic functions compare the numerical values of the student’s and instructor’s answers. In the example from Fig. 1, Excel determines if the student’s responses in column C produce the same numerical answer as the formula used in the IF statement (Fig. 2). In this case, cell C7 might contain any of these correct answers:

- =C6*10
- =10*C6
- =C5*100
- =100*C5
- =10*10*C5
- =100*0.1
- =10*1
• 1.0E+01
• 10

<table>
<thead>
<tr>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Magnitude</td>
<td>Seismogram</td>
</tr>
<tr>
<td>3</td>
<td>M_w</td>
<td>Amplitude</td>
</tr>
<tr>
<td>4</td>
<td>mm</td>
<td>mm</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>0.1</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>1.0</td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>10.0</td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>100.0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Magnitude</td>
<td>Seismogram</td>
</tr>
<tr>
<td>3</td>
<td>M_w</td>
<td>Amplitude</td>
</tr>
<tr>
<td>4</td>
<td>mm</td>
<td>mm</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>0.1</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>=C6*10</td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>=C7*10</td>
</tr>
</tbody>
</table>

Figure 2: Spreadsheet with correct answers as seen by a student (top) and an instructor (bottom).

The strategy discussed thus far checks for an exact answer as calculated by Excel to 15 significant figures. Although this works for many applications, calculated answers can vary slightly because of computer number formats. For example, in Fig. 3 the seismogram amplitude appears to be correct, but the answer is not always an exact match to the quick correct formula in column D because the student has input 100^(1/33)^33 in column C. The answer in cell C8 appears to be exactly 100, but in the course of performing this calculation Excel has slightly changed the value. To account for this, a second quick correct formula in column E checks for answers within 1% of the exact value by using a nested IF statement. To avoid misleading quick correct statements, an instructor can decide on an acceptable range of correct values and design nested logic statements accordingly. This is especially valuable for formulae using rational numbers that require converting numbers written as the quotient of two integers into a decimal value.
2.2. Conditional Formatting

In addition to logic functions, Excel has a Conditional Formatting tool to compare cell values and formulae. In this case, instead of providing separate columns with messages for students, the conditional formatting is applied to the cells where students will provide their answers (Fig. 4). To apply conditional formatting, follow these steps:

1. Click in a cell where students will type an answer.
2. Within the Format menu, select Conditional Formatting.
3. Within the Conditional Formatting tool (Fig. 5), complete the following tasks:
   • In the top central menu, choose the appropriate option from selections such as equal to, between, and greater than.
   • In the top box on the right, specify the appropriate cell value or formula by typing directly or clicking on cells in your spreadsheet.
   • Click on Format to change the cell’s background color, border type, and font style or color for appropriate student responses. Note that if you do not change the format, then the cell’s appearance will remain unchanged in the spreadsheet.
   • Click Add on the bottom of the tool to apply up to three conditions to the cell.
   • Click OK when done.
4. To copy the conditional formatting to other cells, click on the Format Painter in the tool bar symbolized by a paintbrush. Then copy and drag in the appropriate cells as you would when copying formulae.

The explicit instructions provided here are appropriate for Excel 2003 and may require revision for use with Excel 2007.
Figure 4: Answers as seen by a student using the conditional formatting parameters specified in Fig. 5. The green cell contains a correct answer, while the pink and blue cells contain incorrect answers that are too large and too small, respectively.

Figure 5: The Conditional Formatting tool in Excel 2003 with parameters for cell C6 in the spreadsheet shown in Fig. 4.

2.3. Checking for Formulae

If it is important to ensure that students input formulae rather than the numerical answers to complete an exercise in Excel, then instructors may use one of the following strategies:
• To display formulae rather than the resulting values on an entire worksheet, use CONTROL+` (simultaneously hold down the CONTROL key and the accent grave located on the key with the tilde). The spreadsheet will show formulae until you press CONTROL+` again to restore the numerical values. This allows you to quickly switch between seeing the values and the formulae to confirm that students did not simply input numbers. This feature was used to contrast the student and instructor versions in Figures 1-3. If students print out their results, they can print one version showing the values and another showing the formulae. If students complete the spreadsheets in a supervised setting, the instructor can quickly spot-check spreadsheets while students work.

• Require students to type an example formula on the sheet to confirm they know the general Excel equation format (Fig. 6).

• Require calculations that produce enough significant figures to dissuade students from typing in the values (Fig. 6).

<table>
<thead>
<tr>
<th></th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Magnitude</td>
<td>Moment</td>
<td>Quick Correct</td>
</tr>
<tr>
<td>3</td>
<td>M_w</td>
<td>M_o</td>
<td>M_o</td>
</tr>
<tr>
<td>4</td>
<td>dyne-cm</td>
<td>dyne-cm</td>
<td><strong>Change</strong></td>
</tr>
<tr>
<td>5</td>
<td>Student typed value with 3 significant figures</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>5</td>
<td>3.55E+23</td>
<td><strong>Change</strong></td>
</tr>
<tr>
<td>7</td>
<td>6</td>
<td>1.22E+25</td>
<td><strong>Change</strong></td>
</tr>
<tr>
<td>8</td>
<td>7</td>
<td>3.33E+26</td>
<td><strong>Change</strong></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Magnitude</td>
<td>Moment</td>
<td>Quick Correct</td>
</tr>
<tr>
<td>11</td>
<td>M_w</td>
<td>M_o</td>
<td>M_o</td>
</tr>
<tr>
<td>12</td>
<td>dyne-cm</td>
<td>dyne-cm</td>
<td><strong>Change</strong></td>
</tr>
<tr>
<td>13</td>
<td>Student calculated value with appropriate formula</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>5</td>
<td>3.55E+23</td>
<td>Correct</td>
</tr>
<tr>
<td>15</td>
<td>6</td>
<td>1.12E+25</td>
<td>Correct</td>
</tr>
<tr>
<td>16</td>
<td>7</td>
<td>3.55E+26</td>
<td>Correct</td>
</tr>
</tbody>
</table>

Example Formula:
C14 = 10^(1.5*(B14+10.7))

Figure 6: To be correct in this case, a student must type in the correct formula or a number with 15 significant digits to match the calculated value produced by Excel for the moment magnitude \((M_o)\) of an earthquake.

2.4. Hiding and Protecting Answers

The strategy of using quick correct formulae is useless if students can view the answers contained within the logic functions. To use Excel’s password protection feature to prevent students from seeing or changing formulae, follow these steps:

1. Select the range of cells containing the quick correct formulae you wish to protect.
2. On the Format menu, click Cells, and then click the Protection tab located on the top right.
3. Select both Locked and Hidden; click OK.
4. Because the default for all cells is “Locked”, select the range of cells where students will enter their answers.
5. On the Format menu, click Cells, and then click the Protection tab.
6. Deselect Locked; click OK.
8. Input a password, click OK, and reenter the password to confirm. Note that the password is case-sensitive and cannot be retrieved if forgotten, so be sure to record the password for future reference.
9. Click on cells in the spreadsheet to confirm that students can enter data in the appropriate columns.
10. Click on individual cells or use CONTROL+` to confirm that your quick correct formulae are hidden. (If you have followed steps (1) through (8) correctly, then the cells hidden with password protection will appear blank in the formula bar and when using CONTROL+`.)
11. If you have inadvertently locked or hidden some cells and want to make changes, then on the Tools menu, select Protection, Unprotect Sheet and enter your password. Retrace steps (1) through (11) as necessary.

Furthermore, instructors may wish to completely conceal the quick correct columns from students. To hide a column from sight, follow these steps:
1. Click in a cell in the appropriate column.
2. In the Format menu, select Column, Hide before you use the Tools menu to protect the worksheet (i.e., hide the column before step 7 above).
3. To unhide the column, highlight cells in the columns before and after the hidden section. (For example, if you hid column D, highlight cells in columns C and E.)
4. In the Format menu, select Column, Unhide.

Note that the same procedure may be used to hide multiple columns or rows. The explicit instructions provided here are appropriate for Excel 2003 and may require revision for use with Excel 2007.

3. Conclusions

The quick correct method is flexible and may be adapted to many Excel spreadsheet assignments, provided the instructor can supply students with an electronic copy of the template. In addition to checking numerical values, logic functions can also assess multiple choice or simple text answers. The primary caveat of this technique is that the Excel logic functions compare values and do not discriminate between calculated answers and typed numbers (e.g., 10=5*2=40/4). Despite this limitation, in most cases quick correct makes Excel spreadsheet assignments simpler for students to complete and instructors to grade.

4. Acknowledgements

We would like to thank three anonymous reviews for helpful comments as well as Courtney Kniss and Dorien McGee for closely reading the manuscript prior to submis-
sion. The quick correct technique was developed during the Spreadsheets Across the Curriculum project supported by the National Science Foundation, Division of Undergraduate Education, through award DUE 0442629 to H.L. Vacher, University of South Florida, Tampa.